Back to overview
Downtime
2FA Downtime
Dec 20, 2022 at 04:32pm UTC
Resolved
Dec 20, 2022 at 08:44pm UTC
Issue to the data center has now been fixed and all numbers are now fully operational.
Affected services
Created
Dec 20, 2022 at 04:32pm UTC
We are experiencing a minor outage with one of the data centers that is affecting our devices.
Affected services