Back to overview
Degraded

Verizon Issue

May 11 at 07:18am PDT
Affected services
us-central-1
us-central-2
us-central-3
us-central-4
us-central-5

Resolved
May 11 at 11:01am PDT

Service has normalized. Our engineering team is working with Verizon on preventative measures.

Created
May 11 at 07:18am PDT

We are experiencing issues with 2FA code delivery due to downstream carrier Verizon. Our team is investigating.