Back to overview
Downtime

Verizon Outage

Nov 27 at 06:30am PST
Affected services
us-central-2
us-central-3
us-central-4
us-central-5
us-central-6
us-central-7

Resolved
Nov 27 at 04:24pm PST

Verizon fully resolved the issue.

Updated
Nov 27 at 04:03pm PST

Verizon restored services and the lines are slowly coming back online. We'll provide an update as soon as everything is at 100%

Updated
Nov 27 at 03:38pm PST

No updates yet from Verizon. Our team is still on standby.

Updated
Nov 27 at 09:53am PST

Update from Verizon - There is a networking outage affecting multiple cities in the vicinity of the Texas data centers. Verizon networking teams are investigating and working on a resolution.

Updated
Nov 27 at 07:25am PST

The case has been escalated with the Verizon team and their networking team is working on a resolution. No ETA yet.

Created
Nov 27 at 06:30am PST

There is an ongoing Verizon outage affecting cell towers in the region of the data centers. We are waiting for an update from the carrier.