Back to overview
Degraded
Network Impairment - Operator Connect
Nov 20 at 10:00am PST
Resolved
Nov 20 at 11:22am PST
We've received an update from the carrier that the issue has been resolved.
Affected services
Created
Nov 20 at 10:00am PST
We're receiving reports from customers about issues with calling. This is due to a carrier system outage within Microsoft Teams. We are actively working with the underlying phone carrier to resolve the issue.
We’ll update the status once we have an update from the phone carrier.
Affected services